ruby-on-rails – 您已经激活了rake 0.9.0,但是您的Gemfile需要rake 0.8.7

我试图运行rails项目,
我得到

Your bundle is complete! Use `bundle show [gemname]` to see where a bundled gem is installed.

如果我这样做:“bundle install”


我越来越

You have already activated rake 0.9.0, but your Gemfile requires rake 0.8.7

同时做

rake db:migrate
最佳答案
首先,检查以确保在您的Gemfile中提到rake。如果没有,请添加它,并指定版本“您已激活”。

然后,您需要告诉套件更新应用程式使用的耙式版本:

bundle update rake

它会为你更新你的Gemfile.lock。

转载注明原文:ruby-on-rails – 您已经激活了rake 0.9.0,但是您的Gemfile需要rake 0.8.7 - 代码日志