WatchKit应用程序必须具有等于iOS 8.2(是8.3)的部署目标?

我刚刚下载Xcode 6.3 beta 4,我的WatchKit应用程序现在无法构建与一个错误:

Embedded Binary Validation Utility Error
error: WatchKit apps must have a deployment target equal to iOS 8.2 (was 8.3)

iOS应用程序和项目实际上具有7.1的部署目标,并且始终有,但我们一直使用iOS 8.3 SDK为我们的WatchKit组件(使用Swift 1.2)没有问题使用Xcode 6.3 beta 1,2和3。错误只发生与Xcode 6.3 beta 4。

任何人都有这个错误,并知道如何解决它?

选择您的项目设置并转到“TARGETS”。单击您的Watch Kit应用程序,选择构建设置。对于键“iOS部署目标”,您应该找到“iOS 8.3”。由于某种原因,Xcode 6.3 Beta 4想在“iOS 8.2”上有“Debug”和“Release”。现在你的项目应该按预期建立。

这对XCODE 6.3版本仍然是真的!

http://stackoverflow.com/questions/29242067/watchkit-apps-must-have-a-deployment-target-equal-to-ios-8-2-was-8-3

本站文章除注明转载外,均为本站原创或编译
转载请明显位置注明出处:WatchKit应用程序必须具有等于iOS 8.2(是8.3)的部署目标?