ruby-on-rails – 如何找出哪个gem有特定的依赖关系?

我注释掉了一个gem,但“bundle install”仍然不会运行。我如何找出哪个gem对sys-procctable有依赖性?

$ bundle install
Fetching gem metadata from https://rubygems.org/.........
Fetching gem metadata from https://rubygems.org/..
Resolving dependencies...
Could not find sys-proctable-0.9.2 in any of the sources

$ grep proctable Gemfile
  #gem 'sys-proctable', '0.9.2', :path => "vendor/gems"

$ bundle list
Resolving dependencies...
Could not find gem 'rspec-rails (= 2.11.0) ruby' in the gems available on this machine.

$ bundle viz
Resolving dependencies...
Could not find gem 'rspec-rails (= 2.11.0) ruby' in the gems available on this machine.

$ bundle -v
Bundler version 1.3.0

$ ruby -v
ruby 1.9.3p385 (2013-02-06 revision 39114) [i386-cygwin]

Gemfile:http://pastebin.com/9WWMfKtv

我已经尝试过这些问题排查步骤:https://github.com/carlhuda/bundler/blob/1-2-stable/ISSUES.md

在bash shell你可以做:

gem依赖关系name_of_the_gem – 反依赖关系,例如:

gem  dependency  activesupport --reverse-dependencies                               
Gem activesupport-2.3.14
Used by
actionpack-2.3.14 (activesupport (= 2.3.14))
activerecord-2.3.14 (activesupport (= 2.3.14))
activeresource-2.3.14 (activesupport (= 2.3.14))
...
http://stackoverflow.com/questions/15079090/how-do-i-find-out-which-gem-has-a-specific-dependency

本站文章除注明转载外,均为本站原创或编译
转载请明显位置注明出处:ruby-on-rails – 如何找出哪个gem有特定的依赖关系?