android – 如何解决Genymotion在linux ElementaryOS与错误’CXXABI_1.3.8’没有找到

每当我试图启动genymotion(运行命令./genymotion),以下错误显示在我的终端

./genymotion: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /home/mgumiero9/genymotion/libQt5Core.so.5)
./genymotion: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /home/mgumiero9/genymotion/libQt5WebKit.so.5)
./genymotion: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /home/mgumiero9/genymotion/libicui18n.so.52)
./genymotion: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /home/mgumiero9/genymotion/libicuuc.so.52)
./genymotion: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /home/mgumiero9/genymotion/libQt5Qml.so.5)

我想知道如何解决它。

最佳答案
执行以下5个步骤来解决它:

LD_LIBRARY_PATH=/usr/local/lib64/:$LD_LIBRARY_PATH
export LD_LIBRARY_PATH
sudo add-apt-repository ppa:ubuntu-toolchain-r/test
sudo apt-get update
sudo apt-get install gcc-4.9 g++-4.9

在我的情况下,这种方法像一个魅力。

转载注明原文:android – 如何解决Genymotion在linux ElementaryOS与错误’CXXABI_1.3.8’没有找到 - 代码日志