如何在Mac OS X Lion上安装php 5.4?

我已经从php.net下载php 5.4.0和我想升级它在mac os X狮子。

我也想问,如果有人知道如何升级apache。

提前致谢。

我已经安装了它,但我不知道如何配置它与httpd.conf

 /usr/local/bin/php -v
PHP 5.4.0 (cli) (built: Mar  3 2012 02:41:24) 
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2012 Zend Technologies

我试图将此添加到httpd.conf

因为它说,但Web服务器不想启动

LoadModule php5_module libexec/libphp5.so
最佳答案
我有博客关于如何升级您的本地PHP安装到5.4。

归档内容导致外部站点故障:

06000

而已。成功配置后,使用“make test”检查编译,并使用“sudo make install”实际安装新版本。

转载注明原文:如何在Mac OS X Lion上安装php 5.4? - 代码日志