ruby-on-rails – 当你的Gemfile需要一个旧版本的bundler时如何“捆绑安装”?

我在一个较旧的Rails项目中有一个Gemfile。我试图添加一个gem到Gemfile和捆绑安装,但有一个错误:

Bundler could not find compatible versions for gem "bundler":
  In Gemfile:
    rails (= 3.0.0) ruby depends on
      bundler (~> 1.0.0) ruby

  Current Bundler version:
    bundler (1.1.5)

This Gemfile requires a different version of Bundler.

它使用的Rails版本需要bundler〜> 1.0.0,但我已经安装了1.1.5,并将其用于我的其他项目。通常我会使用bundle exec …但是因为这是bundler我们正在谈论,这是一个比这更复杂。我如何添加一个gem到我的Gemfile和运行bundle安装,同时使用bundler的版本,它需要?

最佳答案
首先你需要安装相应版本的bundler:

% gem install bundler -v '~> 1.0.0'
Successfully installed bundler-1.0.22

然后强制rubygems使用你想要的版本(see this post):

% bundle _1.0.22_ install

转载注明原文:ruby-on-rails – 当你的Gemfile需要一个旧版本的bundler时如何“捆绑安装”? - 代码日志