java – Android Studio错误:错误:CreateProcess错误= 216,此版本的%1与您正在运行的Windows版本不兼容

安装Android Studio 2.2预览2并得到此错误:

Error:CreateProcess error=216, This version of %1 is not compatible with the version of Windows you’re running. Check your computer’s system information and then contact the software publisher

屏幕截图:
enter image description here

我重新安装了JDK,还是同样的问题。

我甚至试图使用嵌入式JDK,但仍有同样的问题:

enter image description here

最佳答案
我有同样的问题,但我已经解决了下一个:

1)安装jdk1.8 …

2)在AndroidStudio文件 – >项目结构 – > SDK位置中,选择您的JDK所在的目录,默认情况下,Studio使用嵌入式JDK,但由于某种原因,它会产生error = 216。

3)单击“确定”。

转载注明原文:java – Android Studio错误:错误:CreateProcess错误= 216,此版本的%1与您正在运行的Windows版本不兼容 - 代码日志