您的Ruby版本为2.0.0,但您的Gemfile指定为2.1.0

当我尝试捆绑安装我得到以下消息:

Your Ruby version is 2.0.0, but your Gemfile specified 2.1.0

在我的Gemfile中,我有以下内容:

ruby '2.1.0'

当我在控制台中运行ruby -v时,我得到:

ruby 2.1.0p0 (2013-12-25 revision 44422) [x86_64-darwin12.0]

ruby 2.1.0p0是什么意思?我的Gemfile应该有什么版本,为什么错误告诉我我有Ruby 2.0.0版本?

最佳答案

gem install bundler

要么

gem update bundler 

这可能会解决您的问题

说明:

对于所有新安装的Ruby版本,您应该更新或安装新的捆绑包。

转载注明原文:您的Ruby版本为2.0.0,但您的Gemfile指定为2.1.0 - 代码日志