android – 无法从22.3.0更新ADT 到22.6.1,没有发现更新

参见英文答案 > Error: This Android SDK requires Android Developer Toolkit version 22.6.1 or above                                    11答案                            我有很奇怪的情况。我将Android SDK工具成功升级到版本22.6.1。现在,当我启动ADT(Eclipse)时,它向我显示一条消息,说明如下。

This Android SDK requires Android Developer Toolkit version 22.6.1 or above.
Current version is 22.3.0.v201310242005-887826 

当我按“检查更新”按钮时,Eclipse会显示一条消息,指出“没有找到更新”消息。如果我通过帮助 – 检查更新来实现相同的结果。

如果我打开帮助 – 安装新软件并选择开发工具更新站点我看到新版本的捆绑包,但是当我尝试安装它们时,Eclipse会显示另一个错误消息。

An error occurred while collecting items to be installed
session context was:(profile=profile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,com.android.ide.eclipse.adt,22.6.1.v201403111859-1066720
No repository found containing: osgi.bundle,com.android.ide.eclipse.adt.package,22.6.1.v201403111859-1066720
No repository found containing: osgi.bundle,com.android.ide.eclipse.base,22.6.1.v201403111859-1066720
No repository found containing: osgi.bundle,com.android.ide.eclipse.ddms,22.6.1.v201403111859-1066720
No repository found containing: osgi.bundle,com.android.ide.eclipse.gldebugger,22.6.1.v201403111859-1066720
No repository found containing: osgi.bundle,com.android.ide.eclipse.hierarchyviewer,22.6.1.v201403111859-1066720
No repository found containing: osgi.bundle,com.android.ide.eclipse.traceview,22.6.1.v201403111859-1066720
No repository found containing: osgi.bundle,overlay.com.android.ide.eclipse.adt.overlay,22.6.1.v201403111859-1066720
No repository found containing: org.eclipse.update.feature,com.android.ide.eclipse.adt,22.6.1.v201403111859-1066720
No repository found containing: org.eclipse.update.feature,com.android.ide.eclipse.ddms,22.6.1.v201403111859-1066720
No repository found containing: org.eclipse.update.feature,com.android.ide.eclipse.gldebugger,22.6.1.v201403111859-1066720
No repository found containing: org.eclipse.update.feature,com.android.ide.eclipse.hierarchyviewer,22.6.1.v201403111859-1066720
No repository found containing: org.eclipse.update.feature,com.android.ide.eclipse.traceview,22.6.1.v201403111859-1066720

我试图从官方的Android网站下载,安装和升级新版本的ADT,但我也面临同样的问题。

请按照下列步骤操作:

>帮助>安装新软件
>选择ADT更新站点。

There are two, one with http:// and one with https:// If one doesn’t work, try the other.
HTTPS is not working change it to HTTP and it will work

>选择开发人员工具部分,然后按下一步。
>你应该看到一个对话框,说“这个软件已经安装,更新将被执行”。单击确定将导致22.6.1被安装。

http://stackoverflow.com/questions/22525178/cannot-update-adt-from-22-3-0-to-22-6-1-no-updates-were-found

本站文章除注明转载外,均为本站原创或编译
转载请明显位置注明出处:android – 无法从22.3.0更新ADT 到22.6.1,没有发现更新