Swift 3 iOS兼容性

我是苹果开发的新手,很快我将通过AppStore分发我的应用程序。所以现在我使用Swift 3,默认情况下部署目标设置为iOS 10.0这意味着我将无法使其运行在例如iOS 8-9? “Cos in Swift 3我使用新的功能,在后来的操作系统中不可用
您可以在iOS 8& 9将Deployment Target设置为其中一个版本。 Swift 3.x与iOS 8兼容较新(我不确定,但也可能与iOS 7兼容)。与Swift 2.2(关于系统要求)的唯一区别是您必须使用Xcode 8。

当您将部署目标设置为比iOS 10更早版本的应用程序时,您应该意识到不能使用iOS 10中新增的API(除了使用#available opearator),但使用Swift 3应该没有问题。

编辑:您现在可以使用Xcode 8.0 GM上传使用Swift 3编写的应用程序

http://stackoverflow.com/questions/38067678/swift-3-ios-compatibility

本站文章除注明转载外,均为本站原创或编译
转载请明显位置注明出处:Swift 3 iOS兼容性