如何在Debian Wheezy上安装git 1.8或更高版本

我正在尝试安装更高版本的git(主要是1.8。*或更高版本)。如果我尝试使用apt-get install git安装它,我最终安装版本1.7.10.4。

我已经尝试使用以下方法更改存储库:

add-apt-repository ppa:git-core/ppa
apt-get update
apt-get install git

apt-get更新的输出只是给了我以下,因此,我最终再次安装版本1.7.10.4。

W: Failed to fetch http://ppa.launchpad.net/git-core/ppa/ubuntu/dists/wheezy/main/source/Sources  404  Not Found
W: Failed to fetch http://ppa.launchpad.net/git-core/ppa/ubuntu/dists/wheezy/main/binary-amd64/Packages  404  Not Found

我也尝试使用backport安装git,如下所示:

sudo apt-get install git/wheezy-backports
sudo apt-get -t wheezy-backports install git

我从来没有比apt-get安装git / wheezy-backports更进一步,因为我最终得到以下错误:

E: Release 'wheezy-backports' for 'git' was not found

如何在Debian Wheezy上安装git 1.8。*或更高版本?

最佳答案
我一定会推荐使用backports版本。要使用backports存储库,请记住,您必须将以下行添加到/etc/apt/sources.list中:

deb http://http.debian.net/debian wheezy-backports main

然后你可以用apt-get重试。您将在http://backports.debian.org/Instructions/#index2h2找到完整的说明

转载注明原文:如何在Debian Wheezy上安装git 1.8或更高版本 - 代码日志