JavaScript – IE9 HTTPS安全性受到我的Greasemonkey脚本的威胁?

我在IE9中有一个Greasemonkey-for-IE脚本,它导入jQuery。但是在安全的页面上它不起作用。

我越来越:

SEC7111: HTTPS security is compromised by http://ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.min.js

失败的代码是:

var script = document.createElement("script");
script.setAttribute("src", 
    "http://ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.min.js");

我该怎么做这个工作?该脚本在Firefox中不会导致问题。

大概:使用https://ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.min.js(或不信任第三方CDN(为了安全的网页既可信赖也不妥协)
http://stackoverflow.com/questions/3905840/ie9-https-security-is-compromised-by-my-greasemonkey-script

本站文章除注明转载外,均为本站原创或编译
转载请明显位置注明出处:JavaScript – IE9 HTTPS安全性受到我的Greasemonkey脚本的威胁?