Android Twitter Fabric SDK与支持库冲突

我有Twitter Fabric SDK的问题.当我集成sdk并尝试构建时,我得到了这个错误;

错误:无法找到:com.android.support:support-v4:21.0.0

这是我的gradle.build文件

buildscript {
    repositories {
        maven { url 'https://maven.fabric.io/repo' }
    }

    dependencies {
        classpath 'io.fabric.tools:gradle:1.+'
    }
}
apply plugin: 'com.android.application'

repositories {
    maven { url 'https://maven.fabric.io/repo' }
}

apply plugin: 'io.fabric'

android {
    compileSdkVersion 19
    buildToolsVersion "20.0.0"

    defaultConfig {
        applicationId "com.eventz.android"
        minSdkVersion 14
        targetSdkVersion 19
        versionCode 13
        versionName '1.1.2'
    }

    buildTypes {
        release {
            runProguard false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'
        }
    }
}

dependencies {
dependency.
    compile 'com.android.support:support-v4:21.+'
    compile 'com.android.support:appcompat-v7:20.+'
    compile 'com.google.android.gms:play-services:5.0.+'
    compile project(':facebook')
    compile fileTree(dir:'libs', include:['*.jar'])
    compile files('libs/volley.jar')
    compile files('libs/Parse-1.5.1.jar')

    compile('com.twitter.sdk.android:twitter:1.0.1@aar') {
        transitive = true;
    }
}

我也试图删除该支持库,但我得到了这个错误;

Error:A problem occurred configuring project ':app'.
> Could not resolve all dependencies for configuration ':app:_debugCompile'.
   > Could not resolve com.android.support:support-v4:21.0.0.
     Required by:
         Eventz:app:unspecified > com.android.support:appcompat-v7:20.0.0
      > Could not GET 'https://maven.fabric.io/repo/com/android/support/support-v4/21.0.0/support-v4-21.0.0.pom'. Received status code 401 from server: Unauthorized
   > Could not resolve com.android.support:support-v4:21.0.0.
     Required by:
         Eventz:app:unspecified > com.google.android.gms:play-services:5.0.89
      > Could not GET 'https://maven.fabric.io/repo/com/android/support/support-v4/21.0.0/support-v4-21.0.0.pom'. Received status code 401 from server: Unauthorized
   > Could not resolve com.android.support:support-v4:21.0.0.
     Required by:
         Eventz:app:unspecified > Eventz:facebook:unspecified
      > Could not GET 'https://maven.fabric.io/repo/com/android/support/support-v4/21.0.0/support-v4-21.0.0.pom'. Received status code 401 from server: Unauthorized
   > Could not resolve com.android.support:support-v4:21.0.0.
     Required by:
         Eventz:app:unspecified > com.twitter.sdk.android:twitter:1.0.1 > com.twitter.sdk.android:tweet-ui:1.0.1
      > Could not GET 'https://maven.fabric.io/repo/com/android/support/support-v4/21.0.0/support-v4-21.0.0.pom'. Received status code 401 from server: Unauthorized
来自Fabric的Hemal,我很乐意为此提供帮助.我们需要Android L的支持库作为Twitter工具包的一部分,但是您应该很容易获得Android SDK管理器,然后选择支持库和v20的支持存储库来安装:

一旦安装完毕,你可以重新构建,你应该好好去!让我知道事情的后续.

https://stackoverflow.com/questions/26944483/android-twitter-fabric-sdk-conflict-with-support-library

本站文章除注明转载外,均为本站原创或编译
转载请明显位置注明出处:Android Twitter Fabric SDK与支持库冲突