haskell – 无法在Windows上安装cailo with cabal – 如何在win上获得pkg-config?

Configuring cairo-0.12.0...
setup.exe: The program pkg-config version >=0.9.0 is required but it could not
be found.
cabal: Error: some packages failed to install:
cairo-0.12.0 failed during the configure step. The exception was:
ExitFailure 1

那么如何在Windows上获取pkg-config或者如何安装cairo呢?

最佳答案
你有安装的cairo开发文件吗?回想一下,这与拥有一个cairo dll不同!请参阅其下载页面的Windows部分以获取binaries.此外,您可以运行cabal install -v以便在错误中更详细(如果您仍然卡住,则应该发布).

转载注明原文:haskell – 无法在Windows上安装cailo with cabal – 如何在win上获得pkg-config? - 代码日志