Pip安装到较旧的Python版本

我试图安装mysql-Python使用:

pip install mysql-python

该软件包正在安装在下面,虽然我已经在系统上有Python 2.6.

/Library/Python/2.5/site-packages

如何获取点安装:

/Library/Python/2.6/site-packages

我试过使用:

pip install --install-option="--prefix=/Library/Python/2.6/site-packages/" mysql-python

但是没有办法,它输出:

    Requirement already satisfied (use --upgrade to upgrade): mysql-python in 
    /Library/Python/2.5/site-packages
    Cleaning up...
最佳答案
你应该有pip-2.6.如果你没有pip版本2.6:

你必须安装Python 2.6的setuptools(例如:setuptools-0.6c11-py2.6.egg).那么你有easy_install-2.6.你可以做 :

easy_install-2.6 pip

最后,你有pip版本2.6.要安装mysql-python:

pip-2.6 install mysql-python

转载注明原文:Pip安装到较旧的Python版本 - 代码日志