如何在ubuntu上安装Facebook看门人?

我从github link https://github.com/facebook/watchman.git收到守望员,然后我收到守望者文件夹,并尝试这样做

./autogen.sh

./autogen.sh: 9: ./autogen.sh: aclocal: not found

./autogen.sh: 10: ./autogen.sh: autoheader: not found

./autogen.sh: 11: ./autogen.sh: automake: not found

./autogen.sh: 12: ./autogen.sh: autoconf: not found

为什么我有python 2.7.9.可能是事业吗? (我使用ubuntu 15.04 btw)

最佳答案
您需要安装每个缺少的包.

例如在ubuntu上:

$sudo apt-get install automake  <=== contains autoheader, ...
$sudo apt-get install autoconf

如果你遇到一些错误,如AC_ * undefined,那么你可能需要一个更新的automake版本.您可以从gnu repo下载源代码.请参阅:https://www.gnu.org/software/automake/

转载注明原文:如何在ubuntu上安装Facebook看门人? - 代码日志