如何让Rtools 3.0适用于R 3.0? R找不到安装

我试图让R认识到我已经安装了Rtools.exe.我已经尝试安装在几个不同的地方.但是,每当我重新启动R并加载devtools,我得到相同的错误:

> library(devtools)   
WARNING: Rtools is required to build R packages, but is not currently installed.

Please download and install Rtools 3.0 from http://cran.r-project.org/bin/windows
/Rtools/ and then run find_rtools().

当然,每当我尝试函数find_rtools()我得到相同的错误消息.我已经尝试用帮助文件来解决这个问题,因为devtools的帮助不是很多.我尝试安装在get_path()返回的几个位置,但问题仍然存在.

FYI,目前我的R安装在D:/ R.

有谁有这个问题,更重要的是,任何人都可以帮助我吗?
对不起,如果这是重复的,我已经尝试尽可能多的相关详细信息,所以如果你需要任何澄清,请让我知道.

谢谢,
缺口

最佳答案
batchfiles获取批处理文件Rpathset.bat,在其中正确编辑SET语句,然后从Windows控制台运行R:

Rpathset
Rgui

转载注明原文:如何让Rtools 3.0适用于R 3.0? R找不到安装 - 代码日志