osx – 无法在Mac上安装diagram/arithmoi

我正在尝试安装图表(在一个cabal沙箱中),并且在安装过程中失败,并提供以下消息:

Preprocessing library arithmoi-0.4.1.1...

no location info>:
    Warning: Couldn't figure out LLVM version!
         Make sure you have installed LLVM
ghc: could not execute: opt
Failed to install arithmoi-0.4.1.1
cabal: Error: some packages failed to install:
arithmoi-0.4.1.1 failed during the building phase. The exception was:
ExitFailure 1
diagrams-1.2 depends on arithmoi-0.4.1.1 which failed to install.
diagrams-contrib-1.1.2 depends on arithmoi-0.4.1.1 which failed to install.

我不知道为什么我没有安装LLVM后端,或者为什么它可以执行选择.
任何想法 ? (我在OS 10.8上使用GHC 7.6.3)

最佳答案
您可以使用cabal install arithmoi -f -llvm来构建没有LLVM的arithmoi.

转载注明原文:osx – 无法在Mac上安装diagram/arithmoi - 代码日志