ruby-on-rails – Rails服务器错误:Ruby版本是1.8.7,但是你的Gemfile指定为1.9.3

我输入了一个现有的ruby应用程序,并键入:

$rails s

想在这里启动rails服务器.
但它说:

您的Ruby版本是1.8.7,但你的Gemfile指定为1.9.3

其实我有一个1.8.7,但我删除它.如果我这样做:

$ruby​​ -v

它说:
红宝石1.9.3p286(2012-10-12修订版37165)[x86_64-darwin11.4.2]

所以我不知道如何解决它.你能给我一个帮助吗?

最佳答案
如果您使用rvm,请运行:

$rvm use 1.9.3

转载注明原文:ruby-on-rails – Rails服务器错误:Ruby版本是1.8.7,但是你的Gemfile指定为1.9.3 - 代码日志