android – Qt版本的架构mips,arm,x86缺少

我试图使用Qt-Project V.5.1开发一个Android的应用程序.安装qt-windows-opensource-5.1.0-msvc2012_opengl-x86_64-offline安装程序后,安装过程中可以选择每个组件,我尝试将其设置为Android构建.

在Qt Creator中,我打开工具 – >选项 – > Android并填写我的Android SDK,Android NDK,Ant und opnJDK位置,并勾选“自动创建Android工具链的工具包”.复选框

在这里我得到一个警告说:

Qt版本的架构mips,arm,x86缺少.要添加Qt版本,请选择选项>构建&运行> Qt版本.

当我去Qt版本选项卡时,Android没有选项,也没有选择mips arm或x86. (其实只有QT 5.1.0的MSVC2012 OpenGl 64位选项).添加按钮仅给我指定一个qmake文件的机会.我可以找到的唯一一个是已经参考的“QT 5.1.0 MSVC2012 OpenGl 64位”选项.

任何人都可以告诉我如何在构建和运行选项卡中获取Android选项?
提前致谢.

在“qt-windows-opensource-5.1.0-msvc2012_opengl-x86_64-offline”软件包中,您只能为Windows开发二进制文件.

你今天应该看看the QT download page,有一个“Qt 5.1.1 for Android(Windows 32位,716 MB)”软件包,其中包括为Android开发的二进制文件.或者你可以从源头构建.

翻译自:https://stackoverflow.com/questions/17677456/qt-versions-for-architectures-mips-arm-x86-are-missing

转载注明原文:android – Qt版本的架构mips,arm,x86缺少