无法从源代码在Debian上安装Imagick for PHP,当我安装了6.7.7时,错误说需要6.2.4

拉出我的头发. PHP从源代码构建,一切正常.现在需要安装imagick并且无法安装它.

我在内核3.7.1上使用PHP 5.3.20运行Debian(我的应用程序支持的最后一个版本,不能转到PHP 5.4).

pecl install imagick
...
checking ImageMagick MagickWand API configuration program... found in /usr/bin/Wand-config
checking if ImageMagick version is at least 6.2.4... configure: error: no. You need at least Imagemagick version 6.2.4 to use Imagick.
ERROR: `/tmp/pear/temp/imagick/configure --with-imagick' failed

但是,我安装了6.7.7版本:

# convert --version
Version: ImageMagick 6.7.7-10 2012-11-06 Q16 http://www.imagemagick.org
Copyright: Copyright (C) 1999-2012 ImageMagick Studio LLC
Features: OpenMP

我也尝试安装最新的beta(pecl install imagick-beta),结果相同.还尝试了旧版本2.3.0,结果相同.还尝试下载源代码,phpize和配置 – 相同的结果.

最佳答案
我终于能够自己解决这个问题.我最终做了:

apt-get remove graphicsmagick-libmagick-dev-compat imagemagick imagemagick-common
apt-get autoremove

然后:

apt-get install libmagickwand-dev

最后能够通过pecl安装imagick而不会出错:

pecl install imagick-beta

转载注明原文:无法从源代码在Debian上安装Imagick for PHP,当我安装了6.7.7时,错误说需要6.2.4 - 代码日志