对PayPal API版本#的困惑?

我对版本号完全感到困惑.我找到了显示API版本82.0的文档以及此版本中所做的更改:

https://cms.paypal.com/us/cgi-bin/?cmd=_render-content&content_ID=developer/e_howto_api_nvp_PreviousAPIVersionsNVP

但是,当我在这里使用集成向导时(对于C#/ ASP.NET):

https://www.paypal-labs.com/integrationwizard/ecpaypal/main.php

…它为版本“2.3”创建了一个paypal函数…没有接近版本“82.0”.

有什么不同?除版本号外,它们似乎使用相同的API.如果存在差异,我在哪里可以找到关于版本2.3的API的文档?

集成向导刚刚过时,源于他们开始使用“大版本号”之前的一段时间,例如65,68,81,82,83等.
106.0是当前的最新版本.
您可以通过在https://www.paypalobjects.com/wsdl/PayPalSvc.wsdl加载WSDL并查看ns:version来找到最新版本的API.这是最新的API版本.

新的API版本可能会引入新的更改,但核心功能将保持不变.
例如,并行付款仅适用于API版本65.1(在PAYMENTREQUEST不存在之前).

另请阅读Best practices for API versioning?

翻译自:https://stackoverflow.com/questions/8300308/confusion-about-paypal-api-version-s

转载注明原文:对PayPal API版本#的困惑?