如何解决“您的软件包仅支持平台[”x86-mingw32“],但您的本地平台是[”ruby“,”x86_64-linux“]”

我正在Windows机器上构建一个rails网站但是当我检查我的Gemfile.lock时,我的Travis版本出现以下错误:

Your bundle only supports platforms ["x86-mingw32"] but your local platforms are ["ruby", "x86_64-linux"], and there's no compatible match between those two

名单

这是完整的日志:https://travis-ci.org/bikebike/BikeBike/builds/222395810#L654

我查看了我的Gemfile.lock并说明:

PLATFORMS
  x86-mingw32

这似乎是问题的一部分.我已经尝试将任何特定于Windows的宝石放在平台块中:

platforms 'mswin', 'mingw', 'mswin64', 'x64_mingw' do
  gem 'tzinfo-data'

  group :test do
    gem 'wdm', '>= 0.1.0'
    gem 'win32console', require: false
  end
end

但是Gemfile.lock看起来是一样的.

这是我的完整GemfileGemfile.lock.

我可以通过从git中删除Gemfile.lock文件来暂时解决这个问题,但这不是最佳做法.无论如何,我可以提交我的Gemfile.lock文件并继续在我的Windows机器上开发?

最佳答案
在命令行上运行以下两个命令:

bundle lock --add-platform ruby
bundle lock --add-platform x86_64-linux

这将在Gemfile.lock中添加两个平台

部署到谷歌云时我遇到了同样的错误.但是在运行这两个命令之后,添加了ruby和x86_64-linux并解决了问题.

转载注明原文:如何解决“您的软件包仅支持平台[”x86-mingw32“],但您的本地平台是[”ruby“,”x86_64-linux“]” - 代码日志