ubuntu – 无法安装Composer – php-fpm

最后用nginx和php-fpm启动并运行Ubuntu 12.10.现在我想用Ratchet运行websocket服务器,但我需要先安装Composer.所以我这样做:

 curl -s https://getcomposer.org/installer | php

正如Composer站点指示的那样,但是我收到了以下错误:

The program 'php' is currently not installed.

我认为它可能与最后的PHP有关,所以我把它改成php5-fpm然后它告诉我:

[18-Nov-2012 05:01:30] ERROR: An another FPM instance seems to already listen on /var/run/php5-fpm.sock
[18-Nov-2012 05:01:30] ERROR: FPM initialization failed

有人遇到过这种情况么?有解决方案吗谢谢.

最佳答案
作曲家至少需要php 5.3.2.什么是你的PHP版本?你需要php命令行才能使它工作.正如msg建议的错误,你最好安装’php’.在ubuntu中,您可以使用

  sudo apt-get install php5-cli

转载注明原文:ubuntu – 无法安装Composer – php-fpm - 代码日志