java – 调用需要API级别11(当前最小为8)android.app.Activity#onCreateView

我是android的新手,我正在开发一个Android应用程序.但是我的包行在MainActivity.java类中提供了这个错误.
有人可以告诉我这个的原因吗?
这是我的课,包线给出了这个错误.

package com.example.eventgyaam;


import android.os.Bundle;
import android.support.v7.app.AppCompatActivity;
import android.view.View;
import android.widget.Button;
import android.widget.TextView;

public class MainActivity extends AppCompatActivity  {

int counter;

Button add,sub;
TextView display;

@Override
protected void onCreate(Bundle savedInstanceState) {
    super.onCreate(savedInstanceState);
    setContentView(R.layout.activity_main);
    counter = 0;
    add = (Button) findViewById(R.id.bAdd);
    sub = (Button) findViewById(R.id.bSub);
    display = (Button) findViewById(R.id.tvDisplay);
    add.setOnClickListener(new View.OnClickListener() {

        @Override
        public void onClick(View v) {
            counter++;
            display.setText("Your total is "+counter);
        }
    });
    sub.setOnClickListener(new View.OnClickListener() {

        @Override
        public void onClick(View v) {
            counter--;
            display.setText("Your total is "+counter);
        }
    });

}
}
最佳答案
一,介绍细节. Android API有一定程度的水平,在每个层面上,都可能会推出新的功能,按照here.

创建Android应用程序时,可以指定应用程序运行的最低级别.这在使用-sdk节的清单中完成:有关详细信息,请参阅here.

因此,如果您使用的功能仅在11级可用,您的代码将不会像您指定的那样运行在8级API上.

您必须仅使用目前的最低可用数量或最小值.

至于为什么你似乎在包裹线上收到错误,而对于一个似乎没有显示给我们的源代码的电话,我不能说.由于它是抱怨android.app.Activity#onCreateView根据您的标题,可能会出现一个问题,视图R.layout.activity_main被setContentView膨胀.或者可能是兼容性库本身的一个问题,something that’s not unheard of.

但是,您可能希望考虑到API-11的最低限度,并将appcompat的内容完全删除,而不是为此而努力.根据here,Android用户中只有约2%的用户仍然比Android-3.0 / API-11(截至2016年6月)早.这只会随着时间的推移变小.

转载注明原文:java – 调用需要API级别11(当前最小为8)android.app.Activity#onCreateView - 代码日志