ruby-on-rails – 不能运行rails命令.你的Ruby版本是2.2.1,但是你的Gemfile指定了2.1.4

我不能运行surfer rails或者不能使控制器等我该怎么办?

终端显示以下错误:

Your Ruby version is 2.2.1, but your Gemfile specified 2.1.4
最佳答案
运行ruby -v然后你会看到你已经安装了ruby 2.2.1,但是你的Gemfile中的第一行指定使用ruby 2.1.4.更改Gemfile中的第一行以指定ruby 2.2.1或安装ruby 2.1.4
如果要使用以前版本的ruby 2.1.4.然后使用rvm list命令首先检查是否已经安装.如果它在那里,那么你需要运行rvm使用ruby-2.1.4命令,如果它不在那里使用

rvm install ruby-2.1.4

rvm use ruby-2.1.4

转载注明原文:ruby-on-rails – 不能运行rails命令.你的Ruby版本是2.2.1,但是你的Gemfile指定了2.1.4 - 代码日志