python-3.x – 为Python 3.5安装NumPy

我正在使用python 3.5并且我正在尝试安装NumPy但是当我尝试使用命令从命令提示符安装时:pip install numpy

我收到了很多错误.虽然主要错误似乎在最后:错误:无法找到vcvarsall.bat

我也尝试从http://www.lfd.uci.edu/~gohlke/pythonlibs/#numpy下载numpy二进制文件并使用命令安装:pip install numpy-1.10.4 mkl-cp35-cp35m-win_amd64.whl

但是我得到一个错误:numpy-1.10.4 mkl-cp35-cp35m-win_amd64.whl不是此平台上支持的滚轮.

然后我在https://sourceforge.net/projects/numpy/files/NumPy/1.10.2/找到了一个numpy-1.10.2-win32-superpack-python3.4.exe文件,但是当我尝试运行时,我得到一个错误,我需要Python版本3.4.

我看了,找不到python 3.5.exe的安装程序,我是否需要卸载python 3.5并安装3.4而不是?或者有没有为Python 3.5安装numpy?

我使用的是Windows 10/64位.

最佳答案
获得numpy,scipy,pandas,…的简单方法是安装anaconda.
Anaconda将自动下载并安装最新的模块.
https://www.continuum.io/downloads

我希望这会对你有所帮助.

转载注明原文:python-3.x – 为Python 3.5安装NumPy - 代码日志