如何覆盖Spring Boot依赖项的默认版本?

如何更改Spring Boot依赖项的默认版本?
例如,Spring Boot 1.4使用Thymeleaf 2.1版本,但最新版本的Thymeleaf是3.0.那么如何将2.1版更改为3.0版?
最佳答案
文档describes how to do this.

根据问题上的标签判断,你使用的是Maven.您应该在应用程序的pom.xml中添加一个属性来设置Thymeleaf版本:

<properties>
    <thymeleaf.version>3.0.1.RELEASE</thymeleaf.version>
</properties>

还有一个sample application显示了如何使用可能感兴趣的Thymeleaf 3.0和Spring Boot 1.4.

转载注明原文:如何覆盖Spring Boot依赖项的默认版本? - 代码日志