java – 如何解决错误“没有指定运行时. WLS Web服务项目需要为大多数工具提供运行时.“在发布我的项目时?

我花了一天时间试图解决这个问题,最后找到了解决方案.由于谷歌没有任何关于这个Eclipse错误的答案,我想把它放在每个人身上.

问题:
当我尝试通过eclipse发布项目时,我收到此错误消息:

No runtime specified. WLS Web Service projects require a runtime to be present for most tooling.

如何解决这个问题呢?

最佳答案
(致信Akshay,他最初在他的问题中发布了这个解决方案.)

如果目标运行时未设置为您正在使用的Weblogic版本,则会显示此错误消息.

修复非常简单,只需按照以下步骤操作:

>右键单击Project Folder,然后单击Properties
>选择目标运行时
>选择后,您将看到为项目添加的WebLogic版本
>只需激活复选框并点击“应用”
>完成 – 你的错误应该消失了

转载注明原文:java – 如何解决错误“没有指定运行时. WLS Web服务项目需要为大多数工具提供运行时.“在发布我的项目时? - 代码日志