在docker alpine上安装软件包时不满意的限制

我正在建立一个基于ruby的码头图像:2.3-alpine.我需要为我的rails应用程序安装几个软件包才能正常运行.不幸的是,高山存储库中不存在以下包.

安装它们的方法是什么?

$uname -a
Linux 50642453afd5 4.1.17-boot2docker #1 SMP Thu Feb 11 08:12:31 UTC 2016 x86_64 Linux
$apk add iceweasel
ERROR: unsatisfiable constraints:
  iceweasel (missing):
    required by: world[iceweasel]

要安装的软件包:

> libav-tools
> xfonts-base
> xfonts-75dpi
> iceweasel

最佳答案
截至2016年6月“firefox-esr”replaces Iceweasel.

以下是如何将它安装在Alpine Docker容器中,并运行它以验证它是否已正确安装:

FROM ruby:2.3-alpine
RUN apk add --no-cache firefox-esr
RUN firefox --version

你可能还需要像xvfb这样的虚拟显示器(帧缓冲器).有关详情,请参阅此信息=> https://github.com/rickypc/docker-python-firefox-xvfb/blob/master/Dockerfile

转载注明原文:在docker alpine上安装软件包时不满意的限制 - 代码日志