c – 如何找到AIX盒上安装的xlC版本

所以这应该很简单,但只是想看看我是否做对了.

我试图找出AIX框上安装的xlC编译器的版本.

我尝试了编译器不支持的xlC -v / xlc –version.

我试过lslpp -L | grep xlC

我得到以下输出,但它让我感到困惑(我是UNIX世界的新手)

  xlC.adt.include            8.0.0.0    C     F    C Set ++ Application
  xlC.aix50.rte              8.0.0.0    C     F    C Set ++ Runtime for AIX 5.0
  xlC.cpp                    6.0.0.0    C     F    C for AIX Preprocessor
  xlC.msg.en_US.cpp          6.0.0.0    C     F    C for AIX Preprocessor
  xlC.msg.en_US.rte          8.0.0.0    C     F    C Set ++ Runtime
  xlC.rte                    8.0.0.0    C     F    C Set ++ Runtime

这是安装包上的列表,但是列出了.cpp文件的重要性.

我的盒子上有哪个版本?

6.0或8.0

谢谢

最佳答案
试试xlC -qversion

转载注明原文:c – 如何找到AIX盒上安装的xlC版本 - 代码日志