如何在Centos上安装特定版本的Docker?

我试图在Centos7上安装docker 1.8.2.
文档没有说明版本控制的任何内容.有人可以帮帮我吗?
我试过了

wget -qO- https://get.docker.com/ | sed 's/lxc-docker/lxc-docker-1.8.2/' | sh
+ sh -c 'sleep 3; yum -y -q install docker-engine'

但没有奏效.

编辑:
我执行了:yum install -y http://yum.dockerproject.org/repo/main/centos/7/Packages/docker-engine-1.8.2-1.el7.centos.x86_64.rpm

这有效,但我错过了docker-storage-setup和docker-fetch等选项

最佳答案
因此,您可以使用此命令检查yum仓库中的版本:

sudo yum list docker-engine.x86_64 –showduplicates |排序-r

然后使用它来安装所需的列表版本:

sudo yum -y install docker-engine-< VERSION_STRING>

如果你只是想降级docker包(这可以多次执行,顺便说一下),你可以这样做:

sudo yum降级码头工程师

这将在清理更高版本时将先前版本的docker安装到您当前安装的版本.

你总是可以继续降级,直到得到你想要的那个,但这很烦人,所以我只想采用第一种方法:P

转载注明原文:如何在Centos上安装特定版本的Docker? - 代码日志