docker – 客户端比服务器更新(客户端API版本:1.24,服务器API版本:1.21)

当我做 :

sudo docker version

我得到了这个错误:

Error response from daemon:client is newer than server (client API version: 1.24, server API version: 1.21)

任何人都可以帮我理解我必须做的事情?

最佳答案
Docker在客户端/服务器模型上运行,每个Docker Engine版本都有一个特定的API版本.

Docker的发布版本和API版本的组合如下:

https://docs.docker.com/engine/api/v1.26/#section/Versioning

根据上表,Docker API v1.24用于Docker Engine 1.12.x,Docker API v1.21用于Docker Engine 1.9.x.服务器需要等于或晚于客户端的API版本.

您有以下三个选项.

>将服务器端升级到Docker Engine 1.12.x或更高版本.
>将客户端降级到Engine 1.9.x或更低.
>通过将DOCKER_API_VERSION = 1.21导出到客户端的环境变量,降低运行时使用的API版本.

转载注明原文:docker – 客户端比服务器更新(客户端API版本:1.24,服务器API版本:1.21) - 代码日志