jquery-plugins – Twitter Bootstrap轮播在旧版浏览器上不起作用

Per the docs,这应该足以运行Twitter Bootstrap:

<div class="carousel">
  <div class="carousel-inner">
    <div class="item"></div>
    <div class="item"></div>
    <div class="item"></div>
  </div>
</div>

$('.carousel').carousel()

我还包括jquery.transitions插件,所以我认为它会在旧浏览器中降级.
不幸的是,幻灯片在Firefox 3.6中完全没有移动.为什么?

最佳答案
看起来您需要将幻灯片类添加到您的轮播中才能使简单版本正常工作:

<div class="carousel slide">

样品轮播有它,并且代码中有一个检查:

if (!$.support.transition && this.$element.hasClass('slide')) {
  this.$element.trigger('slide')
  $active.removeClass('active')
  $next.addClass('active')
  this.sliding = false
  this.$element.trigger('slid')
}

但有点奇怪他们没有提到它.

转载注明原文:jquery-plugins – Twitter Bootstrap轮播在旧版浏览器上不起作用 - 代码日志