ruby-on-rails – Bundler找不到gem“activemodel”的兼容版本

试图在rails 4.1中安装mongoid 3.1.6

Bundler找不到gem“activemodel”的兼容版本:
  在Gemfile中:

mongoid (~> 3.1.6) ruby depends on
  activemodel (~> 3.2) ruby

rails (= 4.1.0) ruby depends on
  activerecord (= 4.1.0) ruby depends on
    activemodel (4.1.0)

当mongoid降级到1.0.6时它工作正常,但我需要在轨道4.1中使用mongoid 3.1.6.
有没有解决这个问题的解决方案?

最佳答案
您需要使用4.x版本的mongoid,它使用activemodel> = 4.0.0.这是最新的:

gem 'mongoid', '~> 4.0.0'

转载注明原文:ruby-on-rails – Bundler找不到gem“activemodel”的兼容版本 - 代码日志