javascript – 在docker容器中安装yarn表示缺少依赖项

我正在使用节点:6.7.0图像作为我的docker容器,然后按照纱线的安装指南

sudo apt-key adv --keyserver pgp.mit.edu --recv D101F7899D41F3C3
echo "deb http://dl.yarnpkg.com/debian/ stable main" | sudo tee /etc/apt/sources.list.d/yarn.list

然后我做

apt-get update && apt-get install yarn

但此时我收到一条错误消息

yarn : Depends: nodejs (>= 4.0.0) but it is not going to be installed

我在安装之前回显了节点-v,它也说6.7.0

我缺少什么?

最佳答案
robertklep是对的 – 如果你检查Dockerfile for Node,你会看到他们通过下载TAR而不是通过APT来安装Node.您可以通过运行交互式容器来检查:

> docker run -it node:6.7.0 bash
root@465fa07437c9:/# dpkg -s nodejs
dpkg-query: package 'nodejs' is not installed and no information is available

您可以在Dockerfile中使用NPM:

FROM node:6.7.0
RUN npm install -g yarn

转载注明原文:javascript – 在docker容器中安装yarn表示缺少依赖项 - 代码日志