Raspberry PI上的Mono 3.0.6 – 是否支持?

我按照此page的说明在我的Raspberry PI上安装Mono 3.0.6.很遗憾没有成功:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mono-complete : Depends: mono-devel (= 2.10.8.1-5) but it is not going to be installed
                 Depends: mono-mcs (= 2.10.8.1-5) but it is not going to be installed
                 Depends: mono-gmcs (= 2.10.8.1-5) but it is not going to be installed
                 Depends: mono-dmcs (= 2.10.8.1-5) but it is not going to be installed
                 Depends: mono-csharp-shell (= 2.10.8.1-5) but it is not going to be installed
                 Depends: mono-2.0-gac (= 2.10.8.1-5) but it is not going to be installed
                 Depends: mono-2.0-service (= 2.10.8.1-5) but it is not going to be installed
                 Depends: mono-4.0-service (= 2.10.8.1-5) but it is not going to be installed
                 Depends: monodoc-base (= 2.10.8.1-5) but it is not going to be installed
                 Depends: monodoc-manual (= 2.10.8.1-5) but it is not going to be installed
                 Depends: libmono-cil-dev (= 2.10.8.1-5) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

任何人都知道我支持的是否支持?任何提示或解决方法?
注意:我特别想尝试3.0.6版.我能够安装稳定版本,但有一个阻止我的错误,我希望它在3.0.6中得到修复.

最佳答案
显然目前Mono并没有真正支持armhf,这就是常规的Raspbian“wheezy”发行版.我试过Soft-float Debian“wheezy”,我原来的问题甚至在2.10.8都消失了.当我尝试升级到更新的版本apt-get时,只说“mono-complete已经是最新版本”. Here是故事的长版本.

转载注明原文:Raspberry PI上的Mono 3.0.6 – 是否支持? - 代码日志