如何在Eclipse Window Builder中处理’不兼容的Java版本运行0’?

我在WindowsBuilder中安装了Eclipse,过去它在显示JFrame的设计选项卡方面运行良好.

我刚安装了Intellj,除了目前的SE-9 JVM外还安装了JDK.我的eclipse程序仍然可用,但在打开WindowsBuilder设计时会显示以下内容:

Incompatible Java versions: Eclipse is running under 0, but this Java project has a 
9 Java compliance level, so WindowBuilder will not be able to load classes from this 
project. Use a lower level of Java for the project, or run Eclipse 
using a newer Java version

必须有零,而不是1.8或9.

其他StackExchange答案表明我降级了我的Java版本,但是当我去项目/属性/ java编译器时,它没有用.

我的java编译器链接到SE-9,所以我不确定为什么会出现这个新错误.也许是因为安装了JDK?

最佳答案
这是在Window Builder中检测Java版本字符串的已知错误.从历史上看,实现版本字符串的解析是为了不检查索引位置0的主要版本部分,例如9.0或10.0,但是在索引2处,即1.6,1.7,……

可悲的是,截至今天,在错误报告517291中,我们发现:

Patches welcome, we currently do not have active WB developers.

所以有人必须为这种导致你痛苦的不良行为做出贡献.

因此,对于现在,如果要在Eclipse中使用Window Builder,则必须使用小于或等于1.8的Java版本.作为参考,请参阅greg-449this answer关于此主题的答案.

希望这有助于(现在).

转载注明原文:如何在Eclipse Window Builder中处理’不兼容的Java版本运行0’? - 代码日志