ruby-on-rails – LoadError:无法加载此类文件–bcrypt_ext

我试图在我的rails应用程序上部署devise身份验证.

我收到了这个问题

“无法加载此类文件 – bcrypt_ext”

我认为这是基于Windows的计算机中的常见问题,但其他问题的答案对我没有帮助.

我使用x86 ruby​​和devkit运行Windows 8 x64

最佳答案
尝试

C:\> gem install --no-ri --no-rdoc bcrypt
C:\> cd (path to gems root)\bcrypt-3.1.7-x86-mingw32\ext\mri
C:\(path to gems root)\bcrypt-3.1.7-x86-mingw32\ext\mri> ruby extconf.rb
C:\(path to gems root)\bcrypt-3.1.7-x86-mingw32\ext\mri> make
C:\(path to gems root)\bcrypt-3.1.7-x86-mingw32\ext\mri> make install

参考:https://www.alib.jp/entries/bcrypt_ext_load_error_on_ruby21x

转载注明原文:ruby-on-rails – LoadError:无法加载此类文件–bcrypt_ext - 代码日志