ruby-on-rails – 你已经激活了rake 10.0.4,但你的Gemfile需要rake 10.0.3

我的Gemfile中有什么

gem’rake’,’10 .0.3’#gemfile中的第一行

删除了Gemfile.lock

运行Bundle更新

Ran bundle update rake

运行资产:预编译

我收到以下消息:

You have already activated rake 10.0.4, but your Gemfile requires rake 10.0.3.

捆绑显示输出:

捆绑包含的宝石:

....
* rake (10.0.3)

任何想法为什么我收到此错误消息(我遵循的程序是Stackoverflow的建议摘要)?

最佳答案
在命令中使用bundle exec infront

bundle exec rake assets:precompile

这将解决您的问题.

I always recommend to use "bundle exec" before any such kind of commands.

转载注明原文:ruby-on-rails – 你已经激活了rake 10.0.4,但你的Gemfile需要rake 10.0.3 - 代码日志