ruby-on-rails – 无法加载此类文件 – Nokogiri rails

我写了一个Ruby脚本,我使用Nokogiri.

对于Rails,我在lib /目录中创建了这个模块:

require "net/http"
require "uri"
require 'nokogiri'

Module gk_CT

class CT

  def getCT
    uri = URI.parse("http://www.website.com")
    CT = Net::HTTP.get_response(uri)

    proc = Nokogiri::HTML(CT.body)

    CTQ = Array.new

    CTQ << proc.css('td')

  end

end

在控制器中我有:

require 'gk_CT'

  def show
    @CT= gk_CT::CT.getCT()
    respond_to do |format|
      format.html # show.html.erb
      format.json { render json: @CT}
    end
  end

它总是给我错误:

cannot load such file -- nokogiri

而且我不知道为什么.

最佳答案
如果脚本是实际Rails项目的一部分,那么您需要将Nokogiri添加到Gemfile(使用行’gem’nokogiri’).如果你不在Rails项目中或者没有使用Bundler或者一些如此奇怪的东西,你仍然需要安装gem(gem install nokogiri).

转载注明原文:ruby-on-rails – 无法加载此类文件 – Nokogiri rails - 代码日志