运行Torch / Lua时出错,可能是安装错误

我在http://torch.ch/docs/getting-started.html之后安装了Torch.

但是,当我运行“th”或任何简单代码之类的东西时,我收到以下错误消息:

/ Users / JianxuChen / torch / install / bin / luajit:… rs / JianxuChen / torch / install / share / lua / 5.1 / trepl / init.lua:692:尝试调用字段’setheaptracking'(零值)
堆栈追溯:
    … rs / JianxuChen / torch / install / share / lua / 5.1 / trepl / init.lua:692:在主要块中
    [C]:在功能’需要’
    … Chen / torch / install / lib / luarocks / rocks / trepl / scm-1 / bin / th:104:in main chunk
    [C]:在0x01089f8bc0

有没有人遇到类似的问题,或者对如何解决它有任何想法?

谢谢!

最佳答案
我遇到了同样的问题,并以这种方式解决了它.你的火炬不是最新版本.我所做的不是遵循这个http://torch.ch/docs/getting-started.html.而是下载https://github.com/torch/distro并运行./install.然后它的作品!

转载注明原文:运行Torch / Lua时出错,可能是安装错误 - 代码日志