ruby-on-rails – 在任何来源中都找不到rake-0.9.2.2

这是一个奇怪的.我在运行rake进行测试时遇到此错误,但在迁移时却没有.我正在运行RVM,下面的shell转储应该提供您需要的任何信息.

任何帮助将不胜感激.我见过其他一些人有这个问题,但没有解决方案对我有用(或者他们).

谢谢.

$rake
Could not find rake-0.9.2.2 in any of the sources
Run `bundle install` to install missing gems.
Could not find rake-0.9.2.2 in any of the sources
Run `bundle install` to install missing gems.
Errors running test:units, test:functionals, test:integration!



$ruby -v
    ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-darwin11.4.0]
    $rails -v
    Rails 3.1.6

$more .rvmrc 
rvm ruby-1.9.3-p194@...
$rake db:rollback
==  AddAllLocationsToAlert: reverting =========================================
-- remove_column(...
   -> 0.0320s
==  AddAllLocationsToAlert: reverted (0.0321s) ================================

——-编辑::::

我已经升级到最新的Rails – 3.2.6.即使我使用’bundle exec’,错误仍然会发生. (这对3.2.6来说并不陌生 – 我仍然在3.1下得到了这个问题.)未定义的方法虽然是新的.

Your bundle is complete! Use `bundle show [gemname]` to see where a bundled gem is installed.
$bundle exec rake
Could not find rake-0.9.2.2 in any of the sources
Run `bundle install` to install missing gems.
Could not find rake-0.9.2.2 in any of the sources
Run `bundle install` to install missing gems.
Errors running test:units! #<NoMethodError: undefined method `[]' for nil:NilClass>
Errors running test:functionals! #<RuntimeError: Command failed with status (7): [/Users/ben/.rvm/rubies/ruby-1.9.3-p194/bin...]>
Errors running test:integration! #<RuntimeError: Command failed with status (7): [/Users/ben/.rvm/rubies/ruby-1.9.3-p194/bin...]>

我的Gemfile,按要求:

source 'http://rubygems.org'

gem 'rails', '3.2.6'

group :assets do
  gem 'sass-rails', "  ~> 3.2.5"
  gem 'coffee-rails', "~> 3.2.1"
  gem 'uglifier', '>= 1.2.6'
end

gem 'jquery-rails'

gem 'rake'
gem "mysql2"

gem "squeel"
gem 'tinymce-rails'
gem 'dynamic_form'

gem 'will_paginate'
gem 'devise'
gem 'whitelist'
gem 'rmagick'
gem 'json'
gem 'paperclip'
gem 'acts_as_list', :git => 'https://github.com/swanandp/acts_as_list'
gem 'htmlentities'
gem 'formtastic'
# Bundle gems for the local environment. Make sure to
# put test-only gems in this group so their generators
# and rake tasks are available in development mode:
# group :development, :test do
#   gem 'webrat'
# end
最佳答案
Gemfile中的gem’rake’,“> = 0.9.2”#

然后

$bundle install

然后

$bundle exec rake

如果以上没有奏效:

$rvm all do gem install rake -v 0.9.2.2 #install rake to all ruby​​ versions

然后再次耙

转载注明原文:ruby-on-rails – 在任何来源中都找不到rake-0.9.2.2 - 代码日志