在Mac OS X上更改docker存储驱动程序

我在我的Mac OS X上安装了docker工具箱,我需要将docker存储驱动程序从aufs更改为devicemapper,因为aufs会导致问题.

我找到了offical documentations of docker并按照here解释的方式尝试了它,但是DOCKER_OPTS =“ – storage-driver = devicemapper”对我来说不起作用.

docker info仍告诉我存储驱动程序:aufs.

我没有设法找到位于/ etc / default / docker的文件.

为了记录,我需要更改它才能正确运行CodeClimate CLI.

最佳答案
使用docker-machine创建新VM以选择存储驱动程序时,可以使用–engine-storage-driver标志.

$docker-machine create -d virtualbox \
    --engine-storage-driver devicemapper \
    foobarmachine

docs reference

转载注明原文:在Mac OS X上更改docker存储驱动程序 - 代码日志