macos – 在OSX上安装docker工具箱时出现版本错误

我是docker的新手并且一直关注该指南,尝试安装工具箱版本v1.10.0-rc1.一切似乎进展顺利,直到我尝试hello-world示例然后我得到:

Error response from daemon: client is newer than server (client API
version: 1.22, server API version: 1.21)

我看到有很多关于类似错误的在线,但是到目前为止所有尝试都失败了,并且对docker不熟悉,建议的解决方案有点神秘.

有没有类似的问题,并找到了解决方案?

非常感谢

最佳答案
Docker工具箱正在旧的Mac和/或Windows系统中使用.
今天有不同的方法在你的mac上安装docker.
如果您的mac不是那么旧,请尝试从here开始安装

转载注明原文:macos – 在OSX上安装docker工具箱时出现版本错误 - 代码日志