ruby-on-rails – Ruby on rails: – 找不到RubyGem rails(> = 0)(Gem :: LoadError)

我是Ruby on Rails的新手.我使用http://railsinstaller.org/中的安装程序在我的Windows 7上的rails上安装了ruby.我可以创建一个项目,然后我不是(我不知道我在中间做了什么:-().

完整的错误消息是: –

在创建新项目时: –

c:\Sites>rails new Tickets_Test
E:/Ashish/Ruby192/lib/ruby/1.9.1/rubygems.rb:762:in `report_activate_error': Cou
ld not find RubyGem rails (>= 0) (Gem::LoadError)
        from E:/Ashish/Ruby192/lib/ruby/1.9.1/rubygems.rb:219:in `activate'
        from E:/Ashish/Ruby192/lib/ruby/1.9.1/rubygems.rb:1065:in `gem'
        from E:/Ashish/RailsInstaller/Ruby1.8.7/bin/rails:18:in `<main>'

刚刚获得版本: –

c:\Sites>rails --version
E:/Ashish/Ruby192/lib/ruby/1.9.1/rubygems.rb:762:in `report_activate_error': Cou
ld not find RubyGem rails (>= 0) (Gem::LoadError)
        from E:/Ashish/Ruby192/lib/ruby/1.9.1/rubygems.rb:219:in `activate'
        from E:/Ashish/Ruby192/lib/ruby/1.9.1/rubygems.rb:1065:in `gem'
        from E:/Ashish/RailsInstaller/Ruby1.8.7/bin/rails:18:in `<main>'

知道为什么会发生这种情况吗?

编辑

显然有两个命令提示: –
 Ruby命令提示符: –


 Ruby for rails命令提示符(使用此命令提示符解决问题): –

我正在使用ruby命令提示符.听起来像是一个愚蠢的问题,但是,我不确定是否有“两个”命令提示?

最佳答案
您的系统中似乎有两个Ruby版本,1.9.1和1.8.7. Rails gem似乎只为其中一个安装.我建议你删除其中一个版本,然后重新安装Rails.

转载注明原文:ruby-on-rails – Ruby on rails: – 找不到RubyGem rails(> = 0)(Gem :: LoadError) - 代码日志