Android Studio失败 – 不支持不受支持的主要次要版本51.0

直到昨天,我的Android Studio工作正常并帮助我创建应用程序.但今天,它开始给Gradle错误错误说明不支持主要次要版本51.0并要求我配置gradle.

如果我尝试导回项目,我会得到同样的错误.

 

我的java版本是Android工作室中7个及更早的Android项目正常工作.

$/usr/bin/java -version 
Picked up JAVA_TOOL_OPTIONS: -Dfile.encoding=utf8 
java version "1.7.0_07" Java(TM) SE Runtime Environment (build 1.7.0_07-b10) Java HotSpot(TM) 64-Bit Server VM
(build 23.3-b01, mixed mode)

如何用android-studio解决我的gradle问题?

最佳答案
昨晚,Google团队推出了Gradle插件的0.7.2版本.
这个版本需要Java7.这是个错误.

插件0.7.3将修复它.

你可以从0.7切换回来.在你的插件中为0.7.1,直到Maven Central可以获得0.7.3.

dependencies {
            classpath 'com.android.tools.build:gradle:0.7.1'
        }

转载注明原文:Android Studio失败 – 不支持不受支持的主要次要版本51.0 - 代码日志