使用require-dev与composer和laravel

我使用require-dev作为我的开发工具依赖项.像laravel调试栏,barryvdh ide-helper等…

当我到我的生产服务器并运行“composer update –no-dev –no-scripts”时,一切似乎都没问题.

然后,您意识到必须从app.php数组中删除“dev providers”.

那么使用require-dev是什么意思呢?有没有“providers-dev”数组?

更新:
我是那个我修复它但它不起作用.
我用这个创建文件app / config / local / app.php:

<?php
return array(
    'providers' => append_config(array(
        'Barryvdh\Debugbar\ServiceProvider',
        'Way\Generators\GeneratorsServiceProvider',
        'Barryvdh\LaravelIdeHelper\IdeHelperServiceProvider',
        'Barryvdh\Debugbar\ServiceProvider',
    ))
);

在app / start / global.php的顶部

$env = $app->detectEnvironment(function(){
    $hosts = array(
        'localhost' => 'local',
        '127.0.0.1' => 'local',
    );

    if(isset($hosts[$_SERVER['SERVER_NAME']])){
        return $hosts[$_SERVER['SERVER_NAME']];
    }

});

我尝试回显$env变量,它返回’local’,所以它正在工作.当我打开我的网站时,我看不到调试栏,但其他一切都正常.

有提示吗?

最佳答案
只需将您的开发者提供者添加到app / config / local / app.php并使用append_config:

'providers' => append_config(array(
    'Barryvdh\Debugbar\ServiceProvider',
))

转载注明原文:使用require-dev与composer和laravel - 代码日志