仅包含Python 3.X的发行版

目前有可能吗?我试图在Fedora 19中删除python,但是yum依赖于它.
最佳答案
Python 2和3不兼容,因此对于用它编写的程序需要Python 2.大多数程序仍然在Python 2中.此外,Python 2仍在维护中.

所以你几乎不能在没有Python 2的情况下进行分发.除了像Arch和Gentoo之类的那样.你还必须避免使用Python 2的程序,因为它们不能用Python 3解释器来解释.您可以安装多个版本的Python.我有Python 2.5,2.7和3没有任何问题.

转载注明原文:仅包含Python 3.X的发行版 - 代码日志