linux – Xenomai和Ubuntu

我使用此命令在Ubuntu 11.04中安装了xenomai 2.4.8:

apt-get install libxenomai-dev

现在我想测试一个简单的vxWorks程序,但是当我编译我的程序时,我收到这条消息:

Xenomai: vxworksskin or CONFIG_XENO_OPT_PERVASIVE disabled
(modprobe xeno_vxworks?)

…并且modprobe xeno_vxworks的输出是:

FATAL: Module xeno_vxworks not found

我的问题是,我怎样才能使用xeno_vxworks模块?

最佳答案
您安装了xenomai软件开发库,而不是xenomai软件包本身.更重要的是,快速检查xenomai站点表明您需要编译内核模块(可能是xeno-vxworks)并将其添加到内核才能工作.

指令here适用于Debian而不是ubuntu,但它们至少应该指向正确的方向.

转载注明原文:linux – Xenomai和Ubuntu - 代码日志